AV.io HD Video Artifacts/Tearing [General] (16)
Logitech Brio on Webcaster X2 (Glitches) [General] (11)
Cannot get USB microphone to work [General] (12)
Frame Timing off/Missing with AV.io HD using VGA [General] (16)
Hola mi Webcaster x2 me arrojo el error #803 y luego me dijo que la conexión de RTMP esta cerrado, bueno la verdad es que transmito y se va a negro todo el tiempo de la transmisión, necesito ayuda ya que trabajo con este equipo [Facebook] (16)
User Mode does not survive computer reboot [General] (11)
Webcaster X2 Update Information [General] (3)
Webcaster x2 error with facebook live - page access token [Facebook] (9)
Higher Quality Audio? [General] (7)
Wireless USB Dongle [General] (3)
Feature Request - Layout Transitions [General] (5)
Custom RTMP server question [General] (8)
DVI2USB 3.0 Driver shows always Error code 52 in Windows 10 [Setup, Kit, & Gear] (8)
USB Camera + USB Audio [General] (6)
Error #200 subject does not have premission to live stream on this group [Facebook] (6)
Computer (surface pro) -- HDMI OUTPUT into Webcaster? [General] (6)
A permanent URL for live channel stream [YouTube] (9)
SDI and HDMI parallel use possible? [General] (5)
Best webcam for the Webcaster X2? [General] (7)
Post-Broadcast Video Quality [Facebook] (5)
Got it today and need a quick answer please [General] (4)
Mixer>V-1HD>X2 audio help [YouTube] (5)
How much delay between signal in to output on both You Tube anf Facebook Live [General] (5)
Webcaster X2 will not stay paired to FaceBook [Facebook] (5)
Closed Captioning [Setup, Kit, & Gear] (7)
Stream URL Branding [General] (4)
Broadcasting from the field [Facebook] (5)
Wring power supply [General] (5)
Webcaster X2 Change Log [Webcaster X2] (2)
How is x2 better than using a macbook if I am using audio mixer and video switcher? Stupid question? [General] (3)
Pearl-2 and Skype [Streaming & CDNs] (4)
Schedule events for recording [General] (6)
How to mute audio on HMDI Output [General] (6)
Titler/lower thirds software [General] (6)
Buzz noise when plugging in HDMI monitor [General] (7)
"Clean" Start to YouTube Live Events [YouTube] (5)
X2 message "Can't retrieve persistent broadcast from YouTube" [YouTube] (5)
MP4 Fragmented editing tips? [General] (5)
Videos out of sync [General] (8)
NDI support for NewBlueFX Titler Live 4 [Setup, Kit, & Gear] (4)
HDMI Audio Sample Rate [General] (4)
Brand new device won't boot [General] (3)
Tip for clean audio streaming on Facebook [Feedback] (3)
All Facebook Pages & Groups Missing [Facebook] (6)
Selecting which stream on a channel to start/stop over IP [Streaming & CDNs] (7)
Input/output Error streaming to YouTube [Setup, Kit & Gear] (4)
Switching HDMI outputs [General] (3)
Can Webcaster x2 stream 1080p on Facebook? [Facebook] (2)
Multiple streams question [Streaming & CDNs] (5)
Measure Video Signal Settings with DVI2USB 3.0 [Setup, Kit, & Gear] (5)