Win 7 wont detect DVI2USB 3.0 after installation


#1

I can’t find much info googling in general. I had the version 1 of DVI2USB installed and working but I can’t get our new 3.0 version recognized. I get a ‘device not configured correctly’ error 1. It doesn’t even shown any installed drivers; Windows seemed to ‘recognize’ it as something it labels ‘FX3’. With no driver installed, the update and uninstall buttons are ghosted out. At this point there is either a incompatible driver (hard to believe) or some kind of corruption that needs to be stripped out.
I already tried lots of uninstalling and reinstalling, even tried to strip Epiphan entries in the registry.
Any ideas? thanks.


#2

DVI2USB 3.0 should work without issue with the correct drivers on Windows 7 provided that it is not an embedded operating system or virtual machine.

the correct drivers can be found here under the resources section under Drivers & Software:

If you have older drivers currently installed on the operating system, you will need to ensure that all DVI2USB devices are first disconnected from the computer, that the drivers are uninstalled and that the host computer has been rebooted.

For the software related issue on Windows, try this process for installing:

-Keep the device unplugged for now
-make sure you are logged into an account with administrative privileges (local admin account)
-download the driver (make sure you get the appropriate 32bit or 64bit version)
-close all other programs and windows
-extract the .zip file
-right click on Setup.exe and run it as an administrator
-there may be a pop up asking whether you want to install the driver, click Install
-restart the computer after the installation is complete
-plug the device into the computer

This should resolve the issue


#3

Thank you for the reply.
I have tried all of those things but I think the new was installed without removing the old first. The only thing I can think of at this point is to find out how to manually strip every trace of Epiphan presence on the machine before installing the new software. Is there someplace I can reference? I’d just reinstall Windows but there is too much of other people’s software to deal with until that is a last resort.
thanks


#4

actually I’m going try installing the original DVI2USB drivers then uninstall them. Hopefully the install process doesn’t look somewhere and assume the drivers have been completely installed correctly.


#5

Ensure that no device is connected during the uninstall/install of the drivers or the add/remove of the drivers may not fully take effect


#6

I did as you said and the uninstall/reboot/install/reboot/plug-it-in didn’t work.
Here are some odd things I’ve noticed:
-It keeps detecting ‘FX3’ and looks for window’s updates. Eventually it changes that to ‘DVI2USB 3.0’ and says failed, then also lists just ‘DVI2USB’ and tries to do a window’s update on that as well. If it is attempting a window’s update then it seems like it doesn’t think a proper driver is loaded.


#7

Ok, somebody else came and looked and of course it is now working.


#8

For the benefit of anyone else reading this, when I first plugged in the DVI2USB 3.0, Windows reported one device loaded successfully and one device failed. It looks as though there are separate drivers for USB 2 and USB 3, and only one of them succeeds when the device is first plugged in.

This device always seems to work correctly, regardless.