User Mode does not survive computer reboot


#1

I am using AVio HD to capture video signal.
I define a 900x720 User Mode (using the AVio Capture Config Tool).
The capturing works fine after defining the User Mode and pressing the “Apply” button in the AVio Capture Config Tool and then disconnecting and reconnecting the AVio HD device to the USB port of the capturing workstation.
But if I reboot the workstation, the User Mode disappears (the relevant resolution is not present any more in the list of available capturing modes). To get the User Mode available I have to reapply it using the AVio Capture Config Tool and disconnect-reconnect the AVio HD device again.

Is there a way to store the User Mode permanently in the AVio HD device such that it will survive the reboot of the workstation?

The workstation runs Windows 10 Enterprise LTSC, and the USB controller of the workstation is
Intel® USB 3.0 eXtensible Host Controller 1.0.


#2

The User Modes are saved on the device, so shouldn’t be affected by reboots, unplug/replug, or moving to another system even. Can you confirm what firmware version you are running? The firmware version of the AV.io HD is listed within the Config Tool, the latest released version is 4.0.0


#3

The firmware, I was running, were of version 4.0.0.

After a somewhat deeper investigation, I understand now that the User Mode is indeed stored on the device, but the device fails to report the User Mode to the workstation for particular order of
device-versus-workstation power-up sequence.
Namely, if the workstation is powered up, the operating system is booted and ready to detect the USB devices, and only after that the device is connected to the workstation - everything works fine and the User Mode gets reported to the workstation correctly.
But if the device is connected to the workstation before the workstation is powered-up, when the workstation is powered up - the device boots much faster then the workstation and in this case the device fails to report the User Mode to the workstation correctly.

In my setup the device is connected to the workstation permanently and is located in a closed compartment, so it is impossible to disconnect/reconnect the device to the workstation after each reboot.


#4

Ahh this might just be related to Windows Fast Boot then, you can disable this and hopefully it will fix the issue. Fast startup can be disabled under Control Panel -> Power Options -> “Choose what the power buttons do” -> “Change settings that are currently unavailable”. Then uncheck “Turn on fast startup” and click Save changes


#5

I have tried disabling Windows Fast Boot, exactly as AdamFrame suggested, but unfortunately this did not solve the problem - the User Mode is still not reported if the device is connected to the workstation during the boot.
I have also tried programmatically restarting the AV.io HD device after the booting process is finished.
Namely, I issued the following command from the administrative command prompt to cause the device restart:

devcon.exe restart USB\VID_2B77*

The command indeed causes the device to restart (as the device’s led turns red and then blue again),
but the User Mode is still not reported by the device after this programmatic restart.
Physically disconnecting/reconnecting the device causes it to report the User Mode correctly.

Any other workarounds to try?


#6

This is very strange, we haven’t been able to recreate the problem with any computers here. Are you able to reproduce the problem on multiple computers? If so, is there anything common in between them, such as computer make/model, being on the same domain, or perhaps running some security software?


#7

Indeed, very strange.
I have tested the scenario on three different computers, and the problem is reproduced identically and every time on all three of them. The computers are:

  1. Dell Vostro 3000 Series laptop PC (CPU is Intel Core i3), running Windows-10-Home 64-bit.
  2. No-name desktop PC (CPU is Intel Core i7), running Windows-10-Pro 64-bit.
  3. WMP-22H-MXM Medical-grade PC produced by Wincomm (CPU is Intel Core i5), running Windows-10-Enterprise-LTSC 64-bit.

All three are connected to the same domain (I doubt that the domain has anything to do with the problem), all three of them have no any security or antivirus software whatsoever.

There are some differences in behavior between the case when Windows Fast Boot is enabled and the case when Windows Fast Boot is disabled.
When Windows Fast Boot is enabled and workstation is booted while AV.io HD is already connected - it is impossible to start grabbing using VLC (VLC ignores Media->Open Capture Device->Play command).
When Windows Fast Boot is disabled and workstation is booted while AV.io HD is already connected - VLC starts grabbing but the User Mode is not present among the available modes.
If AV.io HD is disconnected/reconnected when the workstation is already booted - VLC grabs correctly in User Mode, regardless of Windows Fast Boot setting.


#8

Hmm, would it be possible to test on a computer that isn’t on the Domain? This shouldn’t affect anything as far as I know, but it seems to be the only difference between the systems I have tested here and your systems there.


#9

To describe the setup more precisely, all three computers are connected to the same LAN segment.
There is no any Microsoft Server or Domain Controller on this LAN segment, and there are no installations of any software to the hosts on this LAN segment. The computers contain practically virgin
versions of Windows 10 installations (as supplied by the manufacturers).
I have tested the (AV.io HD - related) behavior both in situation when the computers are connected to the LAN, and when the computers are disconnected from the LAN. The behavior was the same.


#10

Hmm ok, I haven’t been able to reproduce this problem at all though. Can I ask, how are you checking the modes available from the AV.io HD? Is this in a third party application? I have been using FFMpeg command line, and this always seems to list the correct modes.


#11

I have been checking the modes available from AV.io HD in two ways, both of them seem to produce pretty consistent results.
The first way is programmatical: I have written a C++ program that enumerates all available modes and displays them (it will be an overkill for you to try reproducing the problem this way).
The second way is using third-party applications.
The most known of them is VLC Media Player. To enumerate all available modes in VLC Media Player I perform the following sequence of steps:

  1. Run the VLC.
  2. Press “Media” in the top-level menu of the VLC application and in submenu that opens
    select “Open Capture Device …”
  3. In the “Open Media” dialog that opens select the right-most tab named “Capture Device”, make sure that the “CaptureMode” drop-down list shows “DirectShow”. In “Video device name” drop-down list find and select “AV.io HD Video”, “Audio device name” can remain “default”, “Video size” edit box can remain empty, press “Advanced Options …” button.
  4. In “Advanced Options” dialog that opens check “Device Properties” check-box and press “OK” button.
  5. While back in “Open Media” dialog, press “Play” button.
  6. In first “Properties” dialog that opens (with Contrast, Brightness, etc. settings) just press “OK”.
  7. In second “Properties” dialog that opens look in the “Stream Format” tab. The “Output Size” drop-down list should contains all the available grabbing modes, including the User-Defined mode.

Another third-party application is amcap.exe
(can be downloaded from https://download.cnet.com/AMCap/3000-13633_4-10504734.html) .
In this application just select “Options” from top-level menu and in submenu that opens select “Video Capture Pin” - the dialog from step #7 of VLC will open.

There are other third-party applications, but I didn’t try FFMpeg - so I’ll try it also.

Thanks!