Canon Vixia HF G50 Camcorder


#1

I have a Canon Vixia HF G50 camcorder, I am using it with the AVio HD capture device. I cannot get the video into computer. (MacBook Pro 16" I-9). The Avio Hd is recognized but no video… I also have a Sony Cybershot HX400V camera and that will work fine… Using the mini-HDMI from both cameras.

I have read that people are using a Canon Vixia HF G40 with this device and it works fine.
I was wondering if anyone has used this camera (the G50) with any success?
Or would I have to have the AVio 4K?

I have tried 3 other computers with the same results(PC & Mac). Am I missing something or is this camera that new that Canon changed something that it won’t work with the AVio HD? Compatibility?

Any help is greatly appreciated.


#2

I would recommend verifying your output settings, as you may need to adjust and play around with them. If your camera is set to output in 4K, the AV.io HD does not have the ability to capture a 4K video signal.


#3

I went back and checked these settings and found that for HDMI output the camera will only do 1920 x 1080 or 1280 x 720. The camera cannot output in 4k through HDMI. So by default it shouldn’t matter what resolution the camera is set at, I did set it at the 1080 one just to be sure. To no avail.

Good suggestion though.

Does it matter if the format is .mp4?


#4

Well, I found the setting that was causing my problems. I had to change the default FPS setting to 59.97 and bam, it worked. All is now working correctly.


#5

I’m glad you were able to resolve the issue!