AV.io 4K problem while capture 4K from Nvidia quadro p2000

avio-4k

#1

Faced the problem that when capturing video from Linux PC with Nvidia Quadro p2000, video signal has strange artifacts.

It’s looks like something wrong with color space because picture is shifted to pink, and something else because picture isn’t sharp.
That problem appear only if source signal is 4K, all smaller resolutions works ideal

Frame rate was 25 or 30 does not affect.

Only one difference that i can catch is in 4K mode color space is YCbCr420, in lower resolutions RGB, according to AVioConfig.
USB connected to windows laptop, tried VLC and OBS. Manually set up settings to NV12 and I420 The picture is a little different but overall the same …

Nvidia has only DP. Then active DP -> HDMI converter is used.
Converter was checked with several 4K monitors, signal is good.

Where can be problem? I tried to set up OBS or VLC but there are no match settings on it…


#2

I would first recommend to ensure you’re on the latest available device firmware. If your AV.io has an outdated firmware it’s possible this could be the cause. You will need to download and install the configuration tool to update the firmware. Both the firmware and the config tool can be found on the device support page.
https://www.epiphan.com/support/avio-4k-software-documentation/?utm_source=Support&utm_medium=Web&utm_campaign=avio-4k

If the issue persists after the firmware update, it’s possible it could be a compatibility issue with the active adapter and I would recommend testing a different make/model


#3

Yes, this is already the latest firmware 4.0.0.40528, this is the first thing I tried.

About active DP -> HDMI converter:
did you have an approved manufacturer or models that you probably know for sure that works?


#4

Unfortunately no we do not specifically purchase and test against third-party adapters