Audio is not working on AFMLE


#1

My work just purchase new streaming equipment and I was tasked to make it all work. I have 10 new Dell Precision laptops running Windows 10 Pro and 10 of AVio SDI. Of the ten laptops, only 3 of them work with no issues. The other 7 will recognize the AVio is connected, show video and audio, and stream using AFMLE. But around the 6 minute mark I lose audio. Then I get error messages that the audio device is not supported or there is a re-sampling output problem. I do not think its a problem with the set up, laptops, or AVio. I have tried different AVio with different computers and the same 3 always work and the other 7 never do. Any help or feedback would be greatly appreciated.


#2

There could be a number of possibilities that could be causing this behavior, however based on the information provided it would seem more likely to be an environmental issue with the host system (Laptop.) If the audio device is suddenly unsupported or re-sampling is taking place, then it could be an indication of the UAC drivers not being recognized correctly. It is also possible that Adobe FMLE could be running into issues as well if you are running a different version on the 3 functional systems.

As Adobe FMLE is no longer supported or being developed by Adobe itself, it does make it slightly harder to troubleshoot. However I would recommend verifying settings on the host systems to see if it provides the expected behavior:

Verify for BIOS updates

Verify USB 3.0 chipset driver updates

Verify and ensure you have the latest available firmware for your AV.io devices. Download the configuration tool and firmware and update the units. Once they have been updated power cycle the device so that the firmware is updated.

Toggle Performance mode in the configuration tool; if Performance mode is checked in the config tool, disable it and test FMLE to see if the same result is produced.

Under Control Panel -> Power Options -> Change plan settings. Make sure that Windows power options are set to “High performance.” Also under Change plan settings -> Change advanced power settings set USB settings -> USB selective suspend setting to Disabled and PCI Express -> Link State Power Management to Off

As these are laptops, ensure that the AC power adapters are connected.

Ensure that you are using the provided 3 FT USB 3.0 cables with the device and that there are no USB extenders in between the AV.io and the laptop that could be reducing the amount of power provided.

If you are connected to a USB hub, please ensure that it is a powered hub and no other device is connected to the hub. The AV.io devices are designed to utilize 100% of the USB bandwidth on that lane. If other devices are connected to that hub it could create a bottleneck with the information being passed through over USB.

I would also recommend testing a different software application if none of these recommendations resolve your issue, if possible.

If the issue persists, I would recommend emailing our support team at info@epiphan.com for further troubleshooting.


#3

Hi Mrenaud,

Thank you for your reply.

Going through your list, I did find a problem in the AV.io SDI Config Properties. I get an error message saying “The drivers for this device are not installed. (Code 28).” Is that a driver I can download from the Epiphan site?


#4

Hello Ldoug,

There are no drivers to install for AV.io. The AV.io series devices utilize the UVC/UAC libraries that are built into the operating system of the computer.
I would recommend, if you have not yet done so, to verify your host systems for BIOS and USB chipset driver updates.
If this does not resolve the issue, we have seen another instance of driver issues with AV.io that was successfully resolved with a “System File Checker” run on the host system. It is possible that the operating system on the laptops did not fully install correctly and may need to be reinstalled if the issue persists.

I would recommend trying a full shutdown and reboot of the system to see if it resolves the issue. If the issue persists then perform a system file checker

https://support.microsoft.com/en-ca/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

If the issue persists beyond that you may need to reinstall the operating system on the host computers