Interlaced Sources Settings

pearl

#1

Hello,
I’ve noticed while using a camera or broadcast switcher that is sending a 1080i 59.94 signal the pearl seems to read that input at 29.97 (I do understand that there are only 29.97 full frames in an interlaced 59.94 signal so this does make sense)However this is causing very poor results with camera or playback motion in the recording. I experienced a better result when I activated the deinterlace option but then lower thirds or graphics that we have overlayed into the input signal externally become very jagged. Im assuming this is because “deinterlace” option isnt a true deinterlace it in fact basically justs drops a full A or B field. Has anyone else experienced this or know of a config that would help fix my issues?


#2

You are correct that the framerate listed here is the number of full frames, so 29.97 from a 59.94i signal makes perfect sense.

We are always deinterlacing, as we don’t record or stream interlaced. The “Enable deinterlacing” checkbox switches between two different types of deinterlacing. With it unchecked we have a form of deinterlacing that loses temporal resolution and will show jaggies when there is motion, but one the upside maintains full horizontal resolution. When the box is checked we switch to a mode that maintains full temporal resolution and removes jaggies, however this does introduce a new kind of visual artifact like you describe as it loses horizontal resolution.

Unfortunately there is always some kind of tradeoff for deinterlacing. It is a matter of choosing between these two for what makes the most sense with your use case/setup.

As an idea for a workaround, is there any way to bring in say the graphics overlay via a progressive signal and then composite this together with the output of the switcher on the Pearl itself?