Impossible to set "Group" Destination

webcaster-x2
streaming
facebook

#1

Hi,

I don’t know what happened, but I was used to stream to the secret / closed FB groups, it went always smooth with any issues. On last Monday (9th of April) I had quite important Live Stram to do but the bad surprise popped up:

  • in the destination list (preferences part) there was only Pages and Events to choose from. (And these events going deeply into past so really annoying with no sense at all)
  • I tried to unlink my account and to associate it again
  • I tried to reboot the device / even to put it back to the factory settings
  • I tried to use different account (my colleague’s which is having admin rights for the page and the group)
  • I tried to change the API authorisation (removed the Events, keeping only Pages and Groups) but the list contained the Pages only…

Nothing helped. Is there any bug or was the API changed? In 14 days I will have to stream again into group so I hope this will be solved till then.

Thank you for your help :wink:

Jirka


#2

Hello,

As you mention there were many destinations listed here you may be running into the limit for the number of publish destinations displayed here. If you reach the limit of 25 then not all destinations will show up. The only way to correct this would be to delete the other destinations from your Facebook account in order for the desired one to appear.


#3

Hi, Adam,

Thank you for the message… but, you advised something I tried, in addition to that, when I disabled events to be possible to stream to, in the settings in the API on Facebook, I had perfectly “clean” list of pages only, even though the Groups were allowed. So what you say is not working at all and it’s unfortunately not the solution to the issue :wink:

And one more thing about the events listed: there is a hyper huge list, containing events into which I am not even subscribed, but someone’s just invited me. Would be great to limit theses to Business events or groups events and not the passed ones but the upcoming ones only :wink:

Apparently there was something changed on the Epiphan side which simply disturb the Groups to be streamed into.

Please try to rectify this, because the situation I am talking about is new, had never this issue before :slight_smile:

Take care!

Jirka


#4

Hmm, ok there are two bugs I have found that are being worked on. One for streaming to secret groups not working, and another for invited / past events being listed sometimes (oddly this doesn’t always happen). Currently I am not sure if this is something we changed or something Facebook changed in their API. Either way we are working on fixing these for a future firmware update, though at the moment I don’t have a timeframe for this.

At the moment the only workarounds I have to suggest would be to either make the Group public, or to stream to a different destination like your timeline or a Page / Event instead. Sorry for the inconvenience here!


#5

I am also having the same problem as the FaceBook Destinations options have disappeared. Something has changed I suspect on the FaceBook API which now doesn’t align with the Webcaster access to FB. I lost all groups and 98% of previous event listings in publishing destinations. I am using a Closed Group to post videos to, that access is now gone. I can only publish video to my timeline, my business page, but no Groups. It was working before NAB but when I returned it was gone.

How did Dan & George publish to Epiphan Group from NAB this week on the Peral Mini or did it work because it was preset before the API changed? Or is the Webcaster X2 is the only device being effected by this bug?


#6

I’m having the same issue and called into support for it. The way I’m now streaming to a group is by streaming on my timeline and then sharing it with the group. doing this it shows in both places, my timeline and the groups timeline. I’ll continue to do this until the bugs are worked ouk. Thanks.


#7

This bug is only affecting Webcaster as this is our only product that pairs to the Facebook API. We are investigating but it seems that Facebook made some changes to the API that broke streaming to groups, hopefully this will be corrected soon.

Regarding the Pearl Mini, it streams using generic RTMP instead of using the API, so it is not affected by the API issues.

For the Webcaster the only workarounds I have currently are to either make the Group public, or to stream to a different destination like your timeline or a Page / Event instead and then share this within the closed Group as David mentions doing.


#8

Just adding that this is happening for me as well. Just got my webcaster going, but no groups, no events, only pages and timeline. I would love to hear once this is resolved! Thank you!


#9

We will of course update when we have more information on this! Currently we are still investigating our options here, as well as waiting to see what other changes Facebook makes on their end.


#10

Hi guys - i believe Facebook doesn’t consider the FB API as a ‘Trusted’ app. If this is changed then this will resolve the issue and people can continue to stream to groups.


#11

We recently purchased this device specifically for the ability to broadcast to Groups. Any updates?


#12

Facebook’s recent API updates related to their ongoing efforts to address privacy and permissions concerns have temporarily caused streaming to Facebook groups and events using Webcaster X2 or Webcaster X1 to not function. We apologize for any inconvenience this has caused and are actively working with Facebook to resolve the issue. Until the problem is resolved, you can continue to stream to your timeline or pages using the encoder. For more information about the recent API changes made by Facebook, you can read this blog. https://developers.facebook.com/blog/post/2018/04/04/facebook-api-platform-product-changes/


#13

What changed today with this issue? I went to set this afternoon’s broadcasts up in the Webcaster X2 and my FaceBook “Groups” were all back in the publish location selection list. In addition the associated pages to my FaceBook account were now mostly restored in the publish location selection list as well. However I did not see “Events” yet in the publish location selection list and I assume that they are still being worked on in the API. What ever you are doing with FaceBook API, keep going its working!


#14

Facebook is still working on its API and optimizing its changes to better determine streaming options and capabilities going forward. We are still waiting on Facebook to provide more information regarding Events, however we’re happy to see that your groups are now available and working again!


#15

Yep, streaming to Facebook Live groups is back up and working!


#16

I think my request fits on this topic. I want to let a facebook friend interact with me during a stream in “picture in picture” as it is able either on a pc or on a mobile phone. When willl Epiphans interfase allow this?

Example:


#17

Interesting idea. Not sure how well that would work with Webcaster X2, or to what level of the API this exist, but I can file the feature request.