Brand new device won't boot


#1

I have just purchased a Webcaster X2 and plugged it in. After pressing the power button, the LCD has shown a “Booting…” screen and a green LED, but it never boots. I have kept it plugged in for many minutes and it is stuck in this state.


#2

Very sorry to hear this! I would recommend you try the factory reset available via the recovery button. To do this disconnect power and have a USB keyboard and HDMI monitor connected, then you can press and hold the recovery button with a pin, keep this held down and connect power to the unit. Once the green LED turns on you can release the recovery button, it will take a minute but the unit will boot to a screen where you can select “wipe data” and “wipe cache”, then afterwards select “reboot system now” this will reset everything and hopefully allow the unit to boot back up properly.


#3

Can you please share a screenshot of the wipe screen? The text is off screen to the left when I try do this. I’ve tried all available aspect ratios and its the same every time.


#4

Hi Adam, how are you?

My device has a simular problem, it’s a brand new (Arrived today) and no display or power led is on.
I did the reset as you mention and the green led turns on but still no display at all.
It’s connect on the internet now, are you able to fix remotely?
Do you recommend any other procedure?


#5

Hello Anderson,

I see here you sent us a support email as well as phone. we will be responding via your support request