None of the USB ports are working on Webcaster X2

dvi2usb-30
webcaster-x2
streaming
facebook

#1

Hello,

I’m unable to get any of the USB ports on the Webcaster to work. I’ve tried 3 different mouses (two with cords and one wireless mouse) and not a single one will work, along with keyboards. Has anyone else seen this and do you have a workaround?


#2

When holding down the “Recovery” button I get the following.



#3

You haven’t been able to connect any USB mice or keyboards? Are these just generic wired keyboards/mice for example from Microsoft or Logitech?

You shouldn’t need to use the recovery button. You can perform factory resets under the Settings _> Backup and Reset menu within the Webcaster X2 itself if this is what you are looking to try.


#4

How do I perform factory reset if I’m unable to get a mouse or keyboard to work? Also, thank you for responding.


#5

A factory reset would require a keyboard or mouse to be working. Can you let me know what specific makes and models of mice/keyboards you have connected that are not working?


#6

I’ve tried Microsoft keyboards and mouses, along with Apple keyboards and mouses of different types. These use to work until a week ago. Nothing works in USB ports that worked before. It’s almost like they have been disabled.


#7

Ah ok, sorry to hear this. The unit would have to be returned for repair then. If you purchased from a third party you should contact this reseller to process the RMA through. If you purchased from us directly you can file an RMA request here: https://www.epiphan.com/support/rma-request/


#8

Thank you for replying. I’ve tried doing an RMA with the reseller on Amazon (Quantum Networks) but they rejected my request. I guess at this point I need to know if I can get it repaired or am I stuck with a broken unit?


#9

Ah sorry to hear that the reseller cannot help here. As long as it is within the 1 year warranty period you can file an RMA with us directly here: https://www.epiphan.com/support/rma-request/