KVM2USB 3.0 No Video


#1

I am having the same issue as this customer with my KVM2USB 3.0

I am using:

  • Intel NUC PC (NUC8i5BEH), I’m using two identical setups, one is the Host, and one is the target being controlled
  • The full PC specs can be found on amazon by searching NUC8i5BEH
  • Ubuntu 18.04 completely up-to-date
  • KVM2USB 3.0 freshly opened from the box yesterday
  • KVM2USB 3.0 Firmware: 4.0.0.39896
  • lsusb shows device 2b77:3661 correctly enumerated
  • /dev/video0 and /dev/video1 devices are populated
  • Chrome and FireFox can stream the target PC’s HDMI connection from /dev/video1
  • opencv library can stream video and capture HDMI images just fine from /dev/video1
  • the Epiphan KVM2USB 3.0 Control Application starts up fine, and recognizes the KVM2USB device when it is plugged in.
  • The Control Application controls the mouse and keyboard just fine on the target PC.
  • The Control Application will not show HDMI video, but instead shows “Please connect your KVM2USB 3.0” …screen shot linked here

It appears quite simply that the Epiphan KVM2USB 3.0 Control Application has a bug that is preventing it from properly streaming the video deice /dev/video1 … all other features of the device / detection are working.

Any thoughts?


#2

Could you send us an email, info@epiphan.com, with all these details? It will open a support ticket that we can assign to team members as needed to assist you.
This could take some back and forth to figure out.


#3

email sent, thanks x


#4

For anyone else who runs into this - on newer kernels the device to read from is /dev/video0, but the software tries to read from /dev/video1. It’s ugly, but you can do:

rm /dev/video1
ln -s /dev/video0 /dev/vide1

to get it working. I have a ticket in requesting this to be configurable.


#5

Same issue here on Ubuntu 19.10 and I confirm this hack works for me too. It probably won’t survive a reboot, but thank god this mean the device work and a fix can be worked out.

Thanks jaymzh


#6

Unfortunately, KVM2USB 3.0 is discontinued now.

A year ago, I prepared an updated version of the control app, but for some reasons it was not published. At least, issues with incorrect device was solved:

Note on my up-to-date Manjaro it crashes. There is simple work around:

  • Use tar.gz archive instead of the AppImage, unpack them
    • Or unpack AppImage: ./KvmApp-1.0.1-20200807-x86_64.AppImage --appimage-extract
  • Delete next files:
    • rm -f lib/libfontconfig.so.1
    • rm -f lib/libfreetype.so.6
  • Optional: edit start.sh and comment out line export FONTCONFIG_PATH=/etc/fonts/
  • Run application via ./start.sh

Video instruction: https://www.youtube.com/watch?v=upOn_1q_yMI

WA is applicable for the officially published KvmApp too.


#7

Hello,
I have the separate problem. When I’m trying to open the KVM app in fullscreen mode and screen resolution of the target PC is 1920x1080 (similar to my host PC), the KVM app suddenly closes. If I’m trying to do this with different resolution of the target and host PC, like 1920x1200 on target and 1920x1080 on host, everything is working fine (with black margins).

Maybe this issue was fixed in some internal builds too?

My host PC configuration is:
KVM app 0.99.27
Windows10|
Intel® Core™ i3-7020U CPU @ 2.30GHz 2.30 GHz|
4,00 GB
Win10 64 bit LTSC
21H2
19044.1415
Windows Feature Experience Pack 120.2212.3920.0


#8

Hello Evgueny,

I am so sorry you’re running into an issue like this. As a support request was also submitted via our chatbot after hours, we will continue troubleshooting via the email you provided.

Thank you and talk soon.