KVM2USB 3.0 app: Stuck in fullscreen


#1

Wrong topic, so I added the KVM2USB 3.0 in the subject. It is for its apps though.

Since I have entered fullscreen, I cannot exit fullscreen. The manual states to press ESC key, but this has no effect. If I close the app and restart it, it start in fullscreen from which I cannot exit and I run in circle.


#2

I’m sorry to see you’re running into device behavior issues! That’s odd behavior. Please email us at info@epiphan.com with more details about your setup and configuration so that we can troubleshoot

Please include device serial number
operating system of your host computer and any relevant screenshots/video samples of the behavior in order to better assist you


#3

Hi Mathieu,

Thanks for reaching in helping me out.

I have created a "little video which I have put into my Dropbox. Here is the link to it…

It will show the 2 issues I am having with your application/device.

  1. Can’t get out of fullscreen/maximize. Either ESC key or CTRL+F have no effect. I tried to unpack the AppImage to see if there was some configuration file in it I could change to fix this, but I am gussing you are using some OS registry to store the settings and I am not familiar at all with QT to find where that might be on my system.

  2. I was not aware of this, but since this patch uvcvideo driver now adds a second device to expose some metadata. When I connect your device, I do get two videoX under /dev, but your application seem to be using the wrong one. I have to overwrite one of the device over the other to get a video.

> sudo ln -s /dev/video2 /dev/video3

My system is Ubuntu 19.10. It’s pretty much a stock OS.


#4

I am including the 2 files which are stderr captured output in the video …

  • [kvmapp.1.trace]
  • [kvmapp.2.trace]

Feel free to ask anything you might need. I would love this device to work properly. If it is stuck in this working state, I will not consider it usable and will unfortunately ask for a refund. :frowning:

Thanks


#5

Linking the first video device over the second does not seem to play well when the connection is idle. Screen goes black, mouse keyboard still works. stderr show:

FOUND PREFERRED FORMAT: 1920x1080, PixFmt: YUYV, FPS: 60
Path: /dev/video3                                          
Set frame rate to: 60/1                                    
VIDIOC_S_PARM error 5, Erreur d'entrée/sortie
Can't open KVM UVC sub-device  
Can't open KVM Device                                      
IS DEVICE CONNECTED: false                                 
DeviceSelected

Error 5 is I/O error.

I have to stop the app, disconnect the USB cable (udev remove both /dev/videoN), reconnect (udev adds both /dev/videoN). I don’t need to loverwrite the link again, both /dev/video[23] are the same inode, so the start and works again,

FOUND PREFERRED FORMAT: 1920x1080, PixFmt: YUYV, FPS: 60
Path: /dev/video3
Set frame rate to: 60/1
QObject::disconnect: Unexpected null parameter
Device opened
**IS DEVICE CONNECTED: true**
DeviceSelected

Until…

Thanks


#6

Thank you for the information. It has been added to your ticket and our Linux team will be following up with your issue as soon as possible. We will continue correspondence via your created ticket