Error; unsupported HDMI in 1920 x 540 interlaced


#1

using a canon eos 750D and get this error. video mode set to 1020*1920 30 frames ( 29 point something)

After writing the above I found that my camera the EOS750/T6I is on the “no good list”. are there any work arounds or do I need to by a new camera house?


#2

You need a “rescaling hdmi switch” like the one featured in a recent video. I’ve ordered one so I can’t confirm it works but there is a good chance it will do the trick.


#3

@GLebedev is correct. You need a scaler/switcher. Haven’t tried this particular one myself, but something like this should do the trick: https://www.amazon.com/HUIERAV-Multi-Viewer-Seamless-Function-Support/dp/B01M8I6SKL/ref=sr_1_4?ie=UTF8&qid=1527094210&sr=8-4&keywords=hdmi+scaler+switch&dpID=41rquFmI%2BuL&preST=SY300_QL70&dpSrc=srch


#4

Yes you are right. I bougt this one , and it works. Else my 300$ for the webcaster would have been a Waste.
https://www.amazon.com/gp/product/B01MU32ULM/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1


#5

Glad you got it working! A lot of the “older” cameras only support interlaced output as they are not really built for live video streaming, so that’s why a conversion is required, but almost all new cameras do have built-in 1080p support.

We do have built-in conversion/de-interlacing in our Pearl family of products such as Pearl Mini, so with any of those devices you wouldn’t need any additional scalers/converters/etc.


#6

Hi everyone. We have Canon XF300 camera which gives interlaced HDMI output, so we are unable to get a signal into webcaster x2.

I assume we need one of these 3:

1 ) HUIERAV HDMI 2x1 Multi-Viewer Seamless Switch with PIP Function

  1. Sewell Echo V2 HDMI to HDMI Upscaler

  2. And also I found this

Has anyone used any of these with Canon XF300, or can explain the difference? Because the first two do not have clear line in the specs saying “Interlace to Progressive Conversion” as opposed to the third option. We are kind of confused and the prices are quite different.

Thanks in advance


#7

Problem solved - in camera menu I changed recording mode from 1080p to 720p