Connection timed out - Youtube streaming


#1

Hi.

I am the technical manager of a cultural venue, and we have a Pearl Mini that we use for streaming events on some of our rooms. We have been using the Pearl Mini for about a year now and it’s been working fine until a few weeks ago.

Recently we are experiencing connection issues while streaming to youtube. We don’t stream to other platforms, so I can’t compare it to other streaming services in order to find out if the issue is with youtube or with our network or the encoder itself. However, we do have a Tricaster that we use for our biggest rooms (Auditoriums), and we don’t experience any problems when streaming from the Tricaster. So it seems safe to assume that there is no issue either with our network or with youtube’s servers.

Yesterday we had a stream that got a “connection timed out” error after about 20 minutes of streaming. What happens is that the encoder loses the connection and is unable to resume it, so we need to create a new stream. This usually works, but it’s annoying both for our technical staff and for our customers as their viewers miss parts of the event and have to get a new link to continue watching the event. However, this didn’t work yesterday. We tried creating a new stream, but it also went down within 5 minutes. Then we attempted a third stream, but this also went down within a couple of minutes. We did a speedtest on our network and had around 500mbps download and upload speeds. We did a few additional speedtests and the network seemed to be stable on our end.

So our conclusion is that the issue has to be with the Pearl Mini. It has worked fine for many months, but suddenly in the last few weeks it has started failing. We have not done any changes to our network. No ports are changed, the unit is running the latest firmware, so there doesn’t seem to be any reason why this should happen. Is the unit failing on us? Is this a common issue? Are others experiencing similar problems? Is there anything we can do to prevent this from happening? Any help would be greatly appreciated!


#2

Hello,

Sorry to hear about this issue! If you could upload the logs from the Pearl to info@epiphan.com we’d be happy to take a look and see if there’s anything that shows up as a potential cause.

You can download the logs on the “Maintenance” page of the Admin Web UI, click on “Download Permanent Logs”. If Permanent Logs is not enabled you would have to re-enable and then re-run the test.

In the meantime you could always try the “sledgehammer” factory reset (bottom of the Maintenance page) and then re-test with default settings. Please keep in mind that a reset will delete all user data on the device, including recordings, network settings, etc.


#3

Thank you for the reply. We are currently very busy with streaming events from our bigger venues and I have not had time yet to download the logs and upload them here. I will try to get it done by the end of the week.


#4

Hello again. I checked now, and permanent logs was not enabled. I have enabled it now and will download the logs when/if we encounter the issue again. I guess you can close this thread for now and I can create a new one when I have the log files.

Thanks for the assistance thus far.