Canon Vixia HFR800 keeps switching to "demo mode" mid-broadcast


#1

I have a Canon Vixia HFR800 and during Facebook broadcasts, the camera will switch to “demo mode” (I think) where it displays the features that the camera has as if it’s on display at Wal-Mart or Best Buy. Does anyone know how to prevent this from happening? Currently, our only option is to wait until it happens, then tap the screen, but it happens so often that it’s become a hassle. Any ideas? Thank you!


#2

I have been using a Canon Vixia HF R700 and recently added an HF R800 camera. I have never had that happen to me. Sorry.
Did you try resetting it to Factory Mode? If you cannot resolve it, you can buy a refurb one from Canon for $160.


#3

Thanks…I figured it out. I had to go into the settings and find “Demo Mode” under one of the tabs and turn it off. I was confused because some of the Vixia cameras have the option under a certain tab, but for the HFR800 its under a different tab.


#4

“one of the tabs.”
“a different tab.”

Seriously? WHICH tab? Specifically?

I assume that you assumed no one ELSE here would have the problem of Demo mode interfering and just starting up out of the blue (I also have that problem, and, for the life of me, I can’t fix it).

I tried deciphering your mysterious “unnamed” tab, but could not come up with one that had Demo Mode under it. As a matter of fact, I could not find ANY tab under any setting that referred to Demo Mode. I know for some this can be a challenge, but if you want to help another who has this ridiculously infuriating demo interfering thing that makes streaming or recording beyond 5 minutes impossible, could you specify exactly how you got there? Example: “Go into the setting that looks like a picture of a wrench. Then go into [insert ACTUAL stated setting on the device]…”

But I honestly can’t find anything to turn off this irritating demo ad that comes on, and NOBODY online, for THIS Canon model, seems to be able to specifically tell how to actually do this, using the actual words and actual symbols that this camera uses in its settings.

Sorry to go off on ya like this, but you successfully FIXED it. Yet you seemingly hide that way for someone to actually duplicate your results.

If you can see your way to help a fellow user who’s about to lose his sanity over such what should be a ridiculously easy thing, I would really appreciate it!


#5

OK- after a lot of trial and error (BTW- the HF R800 DOES NOT have a “Demo Mode” under ANY tab. I don’t know where in the world you got that, ckuesper. Maybe a different model than the Vixia HF R800?), I figured it out.

For you others reading this who might have this demo mode during live stream problem: I was live streaming as well when this happened, just like ckuesper above (Demo Mode starting up right in the middle of your live stream, with all the advertising points, etc). I was Not recording. This is important.

To record, you have to have an SD card inserted. To use the camera live, you can get away without an SD card. But only for a few minutes. Then the Demo comes on.

SOLUTION: Put a cotton-pickin’ SD CARD IN THE SD CARD SLOT. END OF PROBLEM. NO tabs, NO “Demo Mode” settings- DON’T LOOK for those mythical settings in the HF R800- THEY DON’T EXIST! Just put the SD card in, and you’re good. No demo interference. These guys on the web (ckuesper isn’t the only one) telling you to turn it off under Demo Mode in settings are referring to OTHER Canon camcorders that have that setting. Not the HF R800. It simply doesn’t have that setting.


#6

ALSO- the SD card has to be writable! If the SD card you put in the camera is write protected, guess what? After about five minutes, that goddam demo starts right up. But with an SD card that’s able to be written, no demo.


#7

Quick Easy Fix!!!

  1. Little house (Settings button)
  2. Click tools icon (Other Settings)
  3. on middle tab (square with lines in it icon)
  4. Scroll down to “Demo Mode” at end
  5. Click it to turn OFF

#8

Why all the anger…it is simple…when people answered the question about demo mode they had a sd card in the camera like you should anyway. That is why their camera shows a demo mode…yours did not because you did not have a sd card installed. Yes just install a sd card and fixed.