AV.io 4K no Sound from any Source


#1

Hi!

I use OBS (21.1.0 64 Bit) for Streaming and Capturing but the AV_io 4K will not send sound from any source attached to it.
The Video Signal is very good and the low Latency is remarkable, but there is no Sound at all and the Sound Meters in OBS don’t even flicker.
I’ve tried it with a PS4 Pro, a PS3, a PC but nothing to hear.

The Device shows up in Recording Devices, but the Meter next to it won’t move.
I’ve tested it with different HDMI-Cabels, not longe than 2 Meters, connected the Source directly and through an HDMI-Splitter.

Before i decided to wrote down my Problem, i fumbled around today and discovered some strange behaviour:
I deleted the connected Av_io from the Device Manager, restarted and reconnected it -> Windows installed the Drivers and suddenly there was Sound!
But not that Sound that i was looking for. It stuttered, it where distorted and was getting quieter and quieter and then disappeared completely.

At this Point, i am really helpless and had no idea, what is going on.
I would be very grateful for any Idea or Hint that helps me solving this weird Problem.

Thanks!

ZP


#2

This is a very strange error, can you tell me what operating system version you are running on the capture computer? Also, what is the make and model of this computer?


#3

Hi Adam,

sorry, i forgot to post my specs by my first post.

Mainboard: Gigabyte Aorus X399 Gaming 7
CPU: AMD Ryzen Threadripper 1950x (16 x 3,40 GHz)
RAM: 32 GB DDR4 3200MHz
GFX: Gigabyte 1080 TI Aorus Xtreme
OS: Windows 10 64 Bit

I built this Computer by my own, so there is no Maker or Model/Brand.

It doesn’t change anything if i’m using the front or rear USB-Ports, even the USB-Cable was changed.
Ironically, my old Elgato HD60S works pretty fine, no matter on witch USB-Port it is connected to.

Thanks for your help in advance!


#4

This may be a USB compatibility issue of some kind, I would recommend first checking for a Bios update for the motherboard, any driver updates for chipset/USB controller, then also checking for Windows updates. May also be worth checking that the AV.io 4K itself is updated, you can do this using the Config Tool. The Config tool and latest firmware (version 4.0.0) can be downloaded here: https://www.epiphan.com/products/avio-4k/avio4k-downloads/

This could also be related to Windows power states. Under Control Panel -> Power Options -> Change plan settings make sure that Windows power options are set to “High performance”. Also under Change plan settings -> Change advanced power settings set USB settings -> USB selective suspend setting to Disabled and PCI Express -> Link State Power Management to Off. Then check under Device Manager -> Universal Serial Bus controllers that each USB 3 Hub listed here under Properties -> Power Management has “Allow the computer to turn off this device to save power” disabled.

Then we will want to turn off fast startup as this causes Windows to skip initializing some devices. Fast startup can be disabled under Control Panel -> Power Options -> “Choose what the power buttons do” -> “Change settings that are currently unavailable”. Then uncheck “Turn on fast startup” and click Save changes.


#5

The Motherboard runs with the actual BIOS Version F3g, also the Chipset/Drivers are up to date (19.04.2018).

I just checked my Windows Update Status and there are no updates available.

My AV.io has the latest Firmaware installed.

I tweaked some of the Settings in the Power Management, also fast startup has been disabled but after a restart, there is still no sound at all.

A friend of mine came over today and brought his Laptop with, a Lenovo “Ideapad 700-15ISK”.
Specs: i5-6300HQ (4 x 2.30Ghz), GTX950M, 12GB RAM

Unfortunately the same issue on this machine, too.

Could this be a Hardware Problem with the USB-Device itself?


#6

Hmm, ok. It would be extremely unlikely to be a hardware issue with the AV.io itself with just the audio being affected, I would expect there to be visual issues as well with any kind of defect here.

Were these new tests using a direct connection between the source and the AV.io? Were you testing with the source just being a PC/laptop with it set to extend or duplicate the displays?


#7

Hmm, right, that makes sense.
The Video Signal is just perfect, i have no problems with it at all.

Today and the days before i was testing it with a direct connection but also with a HDMI-Splitter in between.
I attached it to my PC and tested it this way:
Monitor is connected via MiniDP
AV.io is connected via HDMI
Desktop is set to duplicate.

As i read in the Forum, duplication may cause issues, so i tried it with an HDMI-Splitter in between and set the Desktop to extend but it hasn’t changed anything.


#8

Hi Adam,

do you have any more hints how i can get this thing to work as it should?


#9

Which version of OBS are you using? I have seen in some specific versions of OBS an audio bug/glitch with many UVC devices where the audio was not coming through, however if you added an audio input capture device and selected the AV.io the audio started working correctly.

Have you tested any other software by chance?


#10

I’m using the latest OBS Version (21.1.0) available.
It seems that no audio is coming through the cable at all, so neither the meter in Windows Sound Settings, nor the Meter in OBS is showing anything.
Also there is no sound in the previously done recordings, doesn’t matter if a sepearte audio input is set or not.

Besides OBS i already tried it with XSplit and Wirecast, but without success.


#11

I would recommend trying a re-update of the latest firmware version to the unit. Ensure nothing is connected to the input of AV.io before performing the update. Once complete power cycle the AV.io device. Test again. If this does not resolve the issue, I would recommend perhaps trying a system file checker
https://support.microsoft.com/en-ca/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system

After the file-check is complete it may require a restart of your system. If the issue persists beyond this please contact our support team at info@epiphan.com


#12

After i did the re-update of the latest firmware and proceeded the SFC (which reported no errors or integrety issues) there is still no sound.

A switch to the Elgato HD60 s, connected to the same usb port the AVio was running seconds before and using the same cables coming from the HDMI-Splitter brings sound instantly.

So i will now contact the support team via email and look forward to solve this issue. :wink:


#13

I also had the same issue but this was evident on a mac a surface book and Asus an an alien wear computer all new update the results where different with only the type of 4 k hdmi splitters


#14

I do think for different systems some hdmi splitters work better 4 this issue because I have 4 different type of computer 4 different 4k splitters and audio work both some mixture and not others in less this a one in a million design flaw meaning it is not ment to work that way and I have a faulty avio 4 k recorder cause it only work with one type of splitter with certain settings for each device


#15

I would recommend to start by ensuring you have the latest firmware installed on your AV.io 4K. Every firmware update addresses bugs that have been discovered or reported. Unfortunately it is very highly unlikely a hardware related issue with AV.io 4K. If there was an issue with the unit itself the audio would likely never work.

Our AV.io series devices are UVC, meaning they operate in the same manner as a webcam. They rely on the third-party software of choice to dictate the encoding settings and behavior. If you’re running into a behavior issue between systems with your configuration, we are more than happy to troubleshoot the issue you are experiencing. As there are so many variables in your reported behavior, I would recommend sending us an email at info@epiphan.com outlining the issue and providing as much detailed information as possible:

What is your video source (or sources) you have tested
What splitters have you tested?
Which splitters were successful/not successful with which configuration and operating systems
What are the make/model of computers you were testing with?
What operating systems were being used?
What firmware was installed on the AV.io 4K?
What third-party software were you using on the computers for use?