AV.io 4K - no signal when capturing medical Stryker stream


#1

Hi I’m trying to capture a 4K stream from a medical camera system (Stryker 1688) and AV.io 4K tells me no signal where I can see it on the 4K monitor connected to the same source and cable.

I know that this stream is 3840 x 2160, (no info about FPS nor color scheme coding), its being passed via HDMI 2.0 cable.

I’m using Win 10 machine (Lenovo Laptop P51), with AV.io 4K updated firmware to ver. 4.0.0.40528. I’m working with VLC 3.0.12 software package as my recording software.

Question I have is:

Does it make any difference for the AV.io 4K device what stream settings I have within VLC software?

(given that so many parameters of the incoming stream are unknown)


#2

Hello! I’m sorry you’re running into this issue! It might be preferable to send in this information via email to info@epiphan.com, it’s easier to stay connected, that said I will try to offer some guidance.

The AV.io 4k should simply capture whatever is being sent to it, regardless of settings, so long as it is within the compatible color spaces. What VLC does with the signal after it is received should not impact what the AV.io sends to it.

What color is the LED on the AV.io? Do you have another video source you could test with it, a camera perhaps? Have you tried using different capture software, like OBS, or AMCAP?

There are a number of variables to consider, but ideally we should confirm that the AV.io functions correctly first.


#3

Hi Zack,

Thank you for the answer. I perfectly understand your point, the LED is blue just FYI.

Your configuration software (one used for firmware updates) in the status bar says “no signal” even though the signal is on this cable.

You’ve mentioned “within the compatible color spaces” what color spaces AV.io 4K support?

I’ve checked frame grabber itself with other 4K signal sources and it works just fine, so I’m trying to understand what is different with that source and how to grab it.

“There are a number of variables to consider” – what should I pay attention to?

From the OEM documentation I only have resolution and cable they use HDMI 2.0

Thank you for all the help

Best Regards,

Maciej Dybiec


#4

Maciej,
My apologies, I had mixed up the color spaces output with input. The AV.io 4k can only output in Color spaces YUY2 (4:2:2), NV12, YV12, and I420 (4:2:0). However, it is only compatible with 8-bit color, so it’s possible that the Stryker is outputting 10-bit color which could certainly cause issues.

Another possibility, though I’d be surprised, is that the Stryker is encrypting the signal with HDCP. The Stryker manual doesn’t mention this, but it also says certain options and features are not covered by the manual and to learn about them one needs to contact a Stryker representative.

The variables I was referring to were things like the cable, the operating system on the PC, the software running on it, basically anything that is involved in the passing of video from the Stryker to the PC through the AV.io 4k. So, establishing that the AV.io 4k was functioning correctly was a priority before trying anything else.

Based on what you’ve told me so far though, it seems as though you might need to contact Stryker at this point to determine more details about the video output, specifically the bit depth of the video and HDCP encryption. If the AV.io 4k is working correctly with other sources, and the Stryker is correctly outputting over that HDMI port to a monitor then the issue likely lies in how the Stryker is outputting that video and only Stryker will be able to tell you that I’m afraid. I hope that this helps!


#5

Thank you Zack, I appreciate it.

I was thinking along the same lines
:wink: let me check with them.

Best Regards,

Maciej Dybiec


#6

Hi Zack,

One more question does this mean that AV.io 4K DOES NOT support HDR10?

Thank you,

Maciej Dybiec


#7

Maciej,
That is correct, it does not support HDR.


#8

Zack, last question: do you have any other product that will support 4K with HDR10?


#9

Unfortunately, we do not at this time, sorry for the inconvenience!